Keep Your Information Secure with a D-Scope VIA Software Upgrade.

The protection of personal information has always been a priority for D-Scope.

We continually enhance the security capabilities of our applications. D-Scope utilizes the security controls that are required by National Institute of Standards & Technologies (NIST) as a guide for good security practices.

To ensure that your D-Scope application is operating with the functions that provide the most secure controls for protecting patient information, we are recommending that applications older than version 5.5, to be upgraded to D Scope VIA, version 6.0.

Please contact your D-Scope representative to learn more about the new security features of VIA 6.0.

Keep Your Information Secure with a D-Scope VIA Software Upgrade.

The protection of personal information has always been a priority for D-Scope.

We continually enhance the security capabilities of our applications. D-Scope utilizes the security controls that are required by National Institute of Standards & Technologies (NIST) as a guide for good security practices.

To ensure that your D-Scope application is operating with the functions that provide the most secure controls for protecting patient information, we are recommending that applications older than version 5.5, to be upgraded to D Scope VIA, version 6.0.

Please contact your D-Scope representative to learn more about the new security features of VIA 6.0.